Hide and fight

Incident Report for Little guys big business

Update

Issue found
Posted Mar 29, 2025 - 07:33 UTC

Identified

We have found the problem and are trying to fix it
Posted Mar 29, 2025 - 07:31 UTC

Investigating

Hide and fight has encountered a error that makes it unplayable little guys big business team is actively trying to fix the error
Posted Mar 29, 2025 - 07:23 UTC